Ignore:
Timestamp:
28/10/10 13:24:59 (10 years ago)
Author:
pjkersha
Message:

Added SOAPFault handling for ndg.soap package. Needs integration into ndg.saml.saml2.binding.soap.server.wsgi.queryinterface to enable SAML query interface to do better error reporting.

Location:
TI12-security/trunk/ndg_saml
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • TI12-security/trunk/ndg_saml

    • Property svn:ignore
      •  

        old new  
        22dist 
        33ndg_saml.egg-info 
         4ndg_saml_env.sh 
  • TI12-security/trunk/ndg_saml/ndg/saml/saml2/binding/soap/server/wsgi/queryinterface.py

    r7634 r7662  
    9393        cls = SOAPQueryInterfaceMiddleware 
    9494        self.__queryInterfaceKeyName = cls.DEFAULT_QUERY_INTERFACE_KEYNAME 
    95         self.__mountPath = None 
    96         self.mountPath = '/' 
     95        self.__mountPath = '/' 
    9796        self.__requestEnvelopeClass = None 
    9897        self.__responseEnvelopeClass = None 
     
    497496         
    498497        if query.version < self.samlVersion: 
    499             msg = ("Query SAML version %r is lower than the supported " 
    500                    "value %r" 
    501                    % (query.version, self.samlVersion)) 
     498            log.debug("Query SAML version %r is lower than the supported " 
     499                      "value %r", query.version, self.samlVersion) 
    502500            response.status.statusCode.value = \ 
    503501                                        StatusCode.REQUEST_VERSION_TOO_LOW_URI 
    504             return 
    505502         
    506503        elif query.version > self.samlVersion: 
    507             msg = ("Query SAML version %r is higher than the supported " 
    508                    "value %r" 
    509                    % (query.version, self.samlVersion)) 
     504            log.debug("Query SAML version %r is higher than the supported " 
     505                      "value %r", query.version, self.samlVersion) 
    510506            response.status.statusCode.value = \ 
    511507                                        StatusCode.REQUEST_VERSION_TOO_HIGH_URI 
    512             return             
     508             
    513509         
    514510    def _initResponse(self): 
Note: See TracChangeset for help on using the changeset viewer.